Skip to content

Commit

Permalink
app-text/libwps: Switch 0.4.4 to --with-sharedptr=c++11
Browse files Browse the repository at this point in the history
Drop boost dependency.

Package-Manager: portage-2.3.0
  • Loading branch information
a17r authored and akhuettel committed Nov 5, 2016
1 parent 5113c54 commit c1f829a
Showing 1 changed file with 39 additions and 0 deletions.
39 changes: 39 additions & 0 deletions app-text/libwps/libwps-0.4.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils

DESCRIPTION="Microsoft Works file word processor format import filter library"
HOMEPAGE="http://libwps.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"

LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~x86"
IUSE="doc debug static-libs"

RDEPEND="
app-text/libwpd:0.10
dev-libs/librevenge
"
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )
"

src_configure() {
econf \
--disable-werror \
--with-sharedptr=c++11 \
$(use_enable debug) \
$(use_with doc docs) \
$(use_enable static-libs static)
}

src_install() {
default
prune_libtool_files --all
}

0 comments on commit c1f829a

Please sign in to comment.