forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
mate-base/mate-control-center: Version bump to 1.16.0
* bump mate-base/mate-desktop and x11-wm/marco version requirement * drop PATCHES Package-Manager: portage-2.3.1
- Loading branch information
Showing
2 changed files
with
89 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST mate-control-center-1.12.1.tar.xz 1304732 SHA256 851f08e69ec8f513b8971262a439c83ef837b2a7467690313672b6a9d9a179fb SHA512 4023511113c993b2420666803a273923b161cd3fff74b07e02f3dd9a80baea47278ca5c10a5baec673818390174a9f0b5c2d8db81c653f48c411cf5f53cc2dce WHIRLPOOL 88a7d704f1e0665d45fa2f4b51c9c588fff1040dc8190fd60548fd49254f98f01ef2cde3e51abf995f88acf6c0c4f40f4d7694927fe028b4b97ea6a6f9dfb461 | ||
DIST mate-control-center-1.14.1.tar.xz 1371360 SHA256 b06deae1feb449a3f3debe27a2a406e64561d68bea7af0bcd311bf5d7dd5641b SHA512 c871486e69174801e6b509848ae416e1b9aa55ca21ea796f7bc9e408ad59d0dfe5feafde59258c8d0019448b620af2fbd73b75cc644c5dc7b031237e3170a30b WHIRLPOOL ea73aa7f726280b4e900d7fdebfe05dd303a901a07ff1c8ac858d35c1ebbf8888edfd317771ae1896338f70d1babcc7dc25d30066dd0943a2c8061107b0587a7 | ||
DIST mate-control-center-1.16.0.tar.xz 1341724 SHA256 155226a482c3d0e402ec49ca53f6691afc5688df8cc958a5e216827e19525e22 SHA512 891cddc3a908bd0a6aeeb05241290f4c0bbc247bc8923c34a1aa1a7ee55d62881c3958a9e65e338d2e79ecae91cdd5641e2186cea44a5fdb762a9a765a065496 WHIRLPOOL c9cd2d204daced5d7ecfcdfa3b337639757250fde5107c92437bdbaa98b0d5ba8c48ef1ca4b7f557080f41f9a6b061831f05a88a0fa45b4b79d7776561f2e419 |
88 changes: 88 additions & 0 deletions
88
mate-base/mate-control-center/mate-control-center-1.16.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,88 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
MATE_LA_PUNT="yes" | ||
|
||
inherit mate | ||
|
||
if [[ ${PV} != 9999 ]]; then | ||
KEYWORDS="~amd64 ~arm ~x86" | ||
fi | ||
|
||
DESCRIPTION="The MATE Desktop configuration tool" | ||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
IUSE="appindicator debug gtk3" | ||
|
||
COMMON_DEPEND=" | ||
dev-libs/atk:0 | ||
>=dev-libs/dbus-glib-0.73:0 | ||
>=dev-libs/glib-2.36:2 | ||
dev-libs/libxml2:2 | ||
>=gnome-base/dconf-0.13.4:0 | ||
>=gnome-base/librsvg-2.0:2 | ||
>=mate-base/libmatekbd-1.6[gtk3(-)=] | ||
>=mate-base/mate-desktop-1.15.1[gtk3(-)=] | ||
>=mate-base/caja-1.8[gtk3(-)=] | ||
>=mate-base/mate-menus-1.6 | ||
>=mate-base/mate-settings-daemon-1.13.1[gtk3(-)=] | ||
>=media-libs/fontconfig-1:1.0 | ||
media-libs/freetype:2 | ||
>=sys-apps/dbus-1:0 | ||
x11-apps/xmodmap:0 | ||
x11-libs/cairo:0 | ||
x11-libs/gdk-pixbuf:2 | ||
x11-libs/libX11:0 | ||
x11-libs/libXScrnSaver:0 | ||
x11-libs/libXcursor:0 | ||
x11-libs/libXext:0 | ||
>=x11-libs/libXi-1.2:0 | ||
x11-libs/libXrandr:0 | ||
x11-libs/libXrender:0 | ||
x11-libs/libXxf86misc:0 | ||
>=x11-libs/libxklavier-4:0 | ||
x11-libs/pango:0 | ||
>=x11-wm/marco-1.13.1[gtk3(-)=] | ||
virtual/libintl:0 | ||
!gtk3? ( | ||
>=dev-libs/libunique-1:1 | ||
media-libs/libcanberra:0[gtk] | ||
>=x11-libs/gtk+-2.24:2 | ||
appindicator? ( dev-libs/libappindicator:2 ) | ||
) | ||
gtk3? ( | ||
>=dev-libs/libunique-3:3 | ||
media-libs/libcanberra:0[gtk3] | ||
>=x11-libs/gtk+-3.0:3 | ||
appindicator? ( dev-libs/libappindicator:3 ) | ||
)" | ||
|
||
RDEPEND="${COMMON_DEPEND}" | ||
|
||
DEPEND="${COMMON_DEPEND} | ||
app-text/rarian:0 | ||
>=app-text/scrollkeeper-dtd-1:1.0 | ||
app-text/yelp-tools:0 | ||
dev-util/desktop-file-utils:0 | ||
>=dev-util/intltool-0.50.1:* | ||
sys-devel/gettext:* | ||
x11-proto/kbproto:0 | ||
x11-proto/randrproto:0 | ||
x11-proto/renderproto:0 | ||
x11-proto/scrnsaverproto:0 | ||
x11-proto/xextproto:0 | ||
x11-proto/xf86miscproto:0 | ||
x11-proto/xproto:0 | ||
virtual/pkgconfig:*" | ||
|
||
src_configure() { | ||
mate_src_configure \ | ||
--disable-update-mimedb \ | ||
--with-gtk=$(usex gtk3 3.0 2.0) \ | ||
$(use_enable appindicator) \ | ||
$(use_enable debug) | ||
} |