Skip to content

Commit

Permalink
app-admin/mongo-tools: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
ultrabug committed Mar 9, 2016
1 parent 7469bbd commit d1e74ce
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/mongo-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mongo-tools-3.0.10.tar.gz 2185555 SHA256 2bd5c984ca8b745b33aeb1e1a8118acd675bc5a408845eb3bb0b70c4fa680d71 SHA512 36d57150f4fb331149a2a7cbcde54253316cf3c5bc8ab195584c057c35b30d5acfabcafa25d314d378388254ac5a0ce75d0d8867e344fb7006593319ce9d028c WHIRLPOOL a6961a1fccb7ba353616fe4bfbe182c6a076f13c23492f4d06d274a0ff4d3f09a811413f77a2353b20801462b3a72f74073e38b8b1b4f4e3abf0026774dbcea2
DIST mongo-tools-3.0.8.tar.gz 2185550 SHA256 b9860339ed59ed57bb29b26c820578c690baa2aaec98fe743561cc95023815f1 SHA512 95ea8377aef747f66ce827300cbc38bfa5b660ad25e4d66cf0dc9899cfe81ff2a67e9383a22c08158fed2d622a6f4d3b315e1234fb6118f246ef17f9cffa129a WHIRLPOOL 00298e54c8fd17a51a3293101defee94219c46929862695e08b2c21a66e59290b341f07c89add38dacfa8295c3fe83ce61cd3911e7489ddd75c2a65721910cce
DIST mongo-tools-3.0.9.tar.gz 2185557 SHA256 41705fe815d189d6985ac6abad0b7467186488600cc3031732a25fea5c69a09f SHA512 d4b8d89242a0ab5b678eec7f9a75ad8cf199769046a399741960c605c7d0dc34d5f5e30d956ff4d51b01bc93b1841e132dc2daf6dade9b32d035f2c2f261e520 WHIRLPOOL ce8911d89d9874f1fbc18b63546b641866e94a7160edd705aece48f05b63a67dfc111cd44940a0956bc1d1e42431b33ea69d5f24eb216e99fcb080b55281ec89
DIST mongo-tools-3.2.3.tar.gz 2227509 SHA256 280a4a5d12a0b36d780fcc6b9c24b48722f39a4acf5cfadf8c9b8679aa953bfd SHA512 c4cb9f12335a87a2c0de6a9dac79aa9e356a1a142868f02d002dd35a9b83f02ecf5cba6be453e9035b513935c77883cddd477369995fc0e174c68c6907b6ddc9 WHIRLPOOL ddcede3235f6931c8832c1254f6d216bdb4148b26a6aaa07df110a5042a6c05f55c8d6706496f93ee16409c2cecd4f7ae0fdd843ef9082679c33259b7caf9fe2
53 changes: 53 additions & 0 deletions app-admin/mongo-tools/mongo-tools-3.0.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils

MY_PV=${PV/_rc/-rc}
MY_P=${PN}-r${MY_PV}

DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
HOMEPAGE="http://www.mongodb.org"
SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="sasl ssl"

# Maintainer note:
# openssl DEPEND constraint, see:
# https://github.com/mongodb/mongo-tools/issues/11

RDEPEND="!<dev-db/mongodb-3.0.0"
DEPEND="${RDEPEND}
dev-lang/go:=
sasl? ( dev-libs/cyrus-sasl )
ssl? ( dev-libs/openssl )"

S=${WORKDIR}/${MY_P}

src_prepare() {
epatch "${FILESDIR}/${PN}-3.0.0-build.patch"
}

src_compile() {
local myconf

if use sasl; then
myconf="${myconf} sasl"
fi

if use ssl; then
myconf="${myconf} ssl"
fi

./build.sh ${myconf}
}

src_install() {
dobin bin/*
}

0 comments on commit d1e74ce

Please sign in to comment.