Skip to content

Commit

Permalink
dev-python/wsgiintercept: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
patricklauer committed Mar 2, 2016
1 parent 1289ede commit d62cb53
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/wsgiintercept/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST wsgi_intercept-0.10.0.tar.gz 30017 SHA256 0f2eb4757c6cdefa4499aff4b6b080e22
DIST wsgi_intercept-0.10.2.tar.gz 30369 SHA256 0294469aa07bbfcf3a490cace2ce54cecda947c9e243559feccb7ea57c0644c7 SHA512 bfcb759e6933279588164e14067017ec0d44524c29cc4e4203b438a9bb253153edb9417c3eadc84bc8a6004bbe9a98eefee25227bc179096002d3167492db945 WHIRLPOOL a536a80d5c51e2f47c43323e81d9b6745157a83bf8c246b0a131824e26280f187d1df5589c88c2157fa67441415d432e83a52f1921617f71c4700975adc12953
DIST wsgi_intercept-0.9.0.tar.gz 28865 SHA256 55b01e89a8752625ee94c13f2d125a73a61ee924f4cfd982983ca28c0a7addeb SHA512 3964fec587408b44d5ea0371b279d7686edaa98591438e5d679f8b954396f93408df13a33c809b6d0338a26da2ad3bad666bf66646da585ca73461a0beb1e439 WHIRLPOOL 090a9e607dcd9c56442ec0aa2f0f4c4aeb6c8764777fa29febf89c53e1fd687c2477db5e818480b4d90b9f846205a592125913f4ac0fdac5ce199a16dedb10b1
DIST wsgi_intercept-0.9.1.tar.gz 29391 SHA256 4eab9fc11fd6abaf74791b6a5a6dd81bdc599d1c385fac834340868489a61d22 SHA512 12c1abb3c88831f90c15e11f8ab45d1262b3547a15192a1fe8ad766bbe36959a3bb4cbdb33cf303ccfd4425e8a355fd73ae6aef4afbf1a1d10f7b753e74a7b1f WHIRLPOOL e901b1719f0cbef675c2b7a0fe73b91a28d1d1efc373c99494c9648d77f1b8145e194d37eaacbbfdffa6f599ea365ef456b9c6fe5ee5d5f32a214628300db660
DIST wsgi_intercept-1.1.2.tar.gz 25517 SHA256 f42772dd0965844b1d0ac2ab03d57f941b73452a8bbcab6d03ad405602f15291 SHA512 59dd14c2c012ff5bc951f03b7ce7a65e70becce300a265e45ed46932bcdc58db89926df773cba846e93d94b1d7458fc7935d8b86b04fa2af81a0e6afd7f1e743 WHIRLPOOL 1a8e6be795836f2c59bcaada1e403730ba116354f6cf114f88a7c15392970e242dd5f340c80b0cbb9a2092b822e693bed0805073f43053369c03e69c7f2b07a3
59 changes: 59 additions & 0 deletions dev-python/wsgiintercept/wsgiintercept-1.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )

inherit distutils-r1

MY_PN="wsgi_intercept"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="WSGI application in place of a real URI for testing"
HOMEPAGE="https://github.com/cdent/python3-wsgi-intercept"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"

SLOT="0"
LICENSE="MIT"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
RDEPEND=""
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/httplib2[${PYTHON_USEDEP}]
>=dev-python/pytest-2.4[${PYTHON_USEDEP}]
>=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/mechanize[${PYTHON_USEDEP}]' python2_7 pypy)
)"
S="${WORKDIR}/${MY_P}"

python_prepare_all() {
# .pyc files cause failure of tests
rm -rf test/__pycache__/ || die

# Req'd to avoid file collisions
sed -e s":find_packages():find_packages(exclude=['test']):" \
-i setup.py || die
# Disable tests connecting to the network; Bug #550710
sed -e 's:test_http_not_intercepted:_&:' \
-e 's:test_https_not_intercepted:_&:' \
-i test/{test_urllib.py,test_http_client.py,test_requests.py} || die
distutils-r1_python_prepare_all
}
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
py.test || die "Tests failed under ${EPYTHON}"
}
python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html//. )
distutils-r1_python_install_all
}

0 comments on commit d62cb53

Please sign in to comment.