forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-benchmarks/sysbench: bump to 1.0.4
Closes: gentoo#4212 Package-Manager: Portage-2.3.4, Repoman-2.3.2
- Loading branch information
1 parent
1a1ed7a
commit d6b6c8c
Showing
3 changed files
with
57 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST sysbench-1.0.3.tar.gz 1450640 SHA256 37e3d1ecd3e3917695bdfa314ebf09201433d3b4c1c7c0bd4a903bde4e69472e SHA512 6680c3d1e0c939bfb27efb2c4982dd4ec92042ad8c3a850f4892dc46bbaaba00a44b2e39d4253a978c49339c275d81fb39a14ddc4c767883fccc89248dd5ca76 WHIRLPOOL c4d1471465abe06fba5e15c7be64e07e3cae7b7e1ca1559b6a3903fd33358835dc246567faecd0fd5465b79c7c0991d59ba69e23de21dc7b719bd602a726b59b | ||
DIST sysbench-1.0.4.tar.gz 1487125 SHA256 fa8dbc56ddfd095b09b977c321f7ebbb12818cfc872542a0bffa195cab0716a1 SHA512 f2725e8f7a265b1f3c4ec4b1a863d9f15b3aa44a0fb358d5e9064e645fe1717cb6988bdf39570342ba6897635ce616e8ddb91e7d891eb391070335de7d15b6cb WHIRLPOOL 922c36ed0735582b54da58c33c0be24000f5ffc72e0cee0491dd1fa0983371aadd800a397abb36a9b3069bf9194e931529d836d3bf7fa509b6a3a41ed5a5bca8 | ||
DIST sysbench-48124f838b00ff83a044fbf046a9d8d0b1602d90.tar.gz 281484 SHA256 d3619b4399e6a77a679932571402cfae85c9fd17541050a77006184b3cad155a SHA512 2dd9bb78343df27894094829708dc133009d8ee65399beafbf38ea88d42be311180a18bf7b76cd41b22482606b7de13840cbdf5fc5841a0d2ed59dd65e34cebe WHIRLPOOL 67874d43c2a1d6cda45f64edfe0961018c9b8f5b13cc68b35dfbcebc1f5c75d2bc0ecfc1cffdcc62fc783fcc8a4cabd0e1bbccea5546bcd907d649b6f3b17c71 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,55 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
|
||
DESCRIPTION="System performance benchmark" | ||
HOMEPAGE="https://github.com/akopytov/sysbench" | ||
SRC_URI="https://github.com/akopytov/sysbench/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="aio mysql postgres test" | ||
|
||
RDEPEND="aio? ( dev-libs/libaio ) | ||
mysql? ( virtual/libmysqlclient ) | ||
postgres? ( dev-db/postgresql:= )" | ||
DEPEND="${RDEPEND} | ||
app-editors/vim-core | ||
dev-lang/luajit:= | ||
dev-libs/concurrencykit | ||
dev-libs/libxslt | ||
sys-devel/libtool:= | ||
virtual/pkgconfig | ||
test? ( dev-util/cram )" | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed -i -e "/^htmldir =/s:=.*:=/usr/share/doc/${PF}/html:" doc/Makefile.am || die | ||
|
||
# remove bundled libs | ||
rm -r third_party/luajit/luajit third_party/concurrency_kit/ck third_party/cram || die | ||
|
||
./autogen.sh || die | ||
} | ||
|
||
src_configure() { | ||
local myeconfargs=( | ||
$(use_enable aio aio) | ||
$(use_with mysql mysql) | ||
$(use_with postgres pgsql) | ||
--without-attachsql | ||
--without-drizzle | ||
--without-oracle | ||
--with-system-luajit | ||
--with-system-ck | ||
) | ||
|
||
econf "${myeconfargs[@]}" | ||
} | ||
|
||
src_test() { | ||
emake check test | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters