Skip to content

Commit

Permalink
dev-python/pyzmq: Bump to 20.0.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 14, 2020
1 parent 16076fc commit d7cc2b8
Show file tree
Hide file tree
Showing 2 changed files with 88 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pyzmq/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pyzmq-19.0.1_p20200608.tar.gz 390927 BLAKE2B d70a2f615782cc5a53ed2ffab4d5549bc5d15cc1e0e63f640a357fe8575ca327a5976a3e8b11d97c236a31ca17025f37fe423d166b684b5c4aafc139a0941492 SHA512 7f077ed3858c226eb1e3f5e51dfb5d4b517ec94357b37cc66d17cfe2543786b86627ce7eb4c12785a2709a499af998d02642d972c119a637df3cec5201e909d1
DIST pyzmq-19.0.2.tar.gz 390927 BLAKE2B d70a2f615782cc5a53ed2ffab4d5549bc5d15cc1e0e63f640a357fe8575ca327a5976a3e8b11d97c236a31ca17025f37fe423d166b684b5c4aafc139a0941492 SHA512 7f077ed3858c226eb1e3f5e51dfb5d4b517ec94357b37cc66d17cfe2543786b86627ce7eb4c12785a2709a499af998d02642d972c119a637df3cec5201e909d1
DIST pyzmq-20.0.0.gh.tar.gz 393041 BLAKE2B 1f22f556f5d0f2755c2e56411fdb9f583bbdfad6315e4e72fbaa1fb18d0ad5436ee0ee8d17497641421cea3f4e1b53b8ff85bf7ced96c8f1c80db0be901ca3d5 SHA512 30359e501e76d6ec14175622d6c970d9ec0f227b372d2b1c6e6650be812dd47017b797a016f5a2da83f72d00536e64d2f005a38003c9a1b4fbb7266f2640782d
87 changes: 87 additions & 0 deletions dev-python/pyzmq/pyzmq-20.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="threads(+)"

inherit flag-o-matic distutils-r1 toolchain-funcs

DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
HOMEPAGE="
https://www.zeromq.org/bindings:python
https://pypi.org/project/pyzmq/
https://github.com/zeromq/pyzmq/"
SRC_URI="
https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz"

LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="+draft"

DEPEND="
>=net-libs/zeromq-4.2.2-r2:=[drafts]
"
# it uses cffi backend for pypy, cython backend for cpython
RDEPEND="${DEPEND}
$(python_gen_cond_dep '
dev-python/py[${PYTHON_USEDEP}]
dev-python/cffi:=[${PYTHON_USEDEP}]
' pypy3)
"
BDEPEND="
$(python_gen_cond_dep '
dev-python/cython[${PYTHON_USEDEP}]
' 'python*')
test? (
>=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest
distutils_enable_sphinx docs \
"dev-python/numpydoc"

python_configure_all() {
tc-export CC
append-cppflags -DZMQ_BUILD_DRAFT_API=$(usex draft '1' '0')
}

python_compile() {
esetup.py cython --force
distutils-r1_python_compile
}

python_test() {
local deselect=(
# broken tests
zmq/tests/test_asyncio.py::TestAsyncioAuthentication::test_curve_user_id
zmq/tests/test_asyncio.py::TestThreadAuthentication::test_curve_user_id
zmq/tests/test_auth.py::TestThreadAuthentication::test_curve_user_id
zmq/tests/test_constants.py::TestConstants::test_draft
zmq/tests/test_draft.py::TestDraftSockets::test_client_server
zmq/tests/test_draft.py::TestDraftSockets::test_radio_dish
zmq/tests/test_message.py::TestFrame::test_buffer_numpy
zmq/tests/test_message.py::TestFrame::test_bytes
zmq/tests/test_message.py::TestFrame::test_frame_more
zmq/tests/test_message.py::TestFrame::test_lifecycle1
zmq/tests/test_message.py::TestFrame::test_lifecycle2
zmq/tests/test_message.py::TestFrame::test_memoryview_shape
zmq/tests/test_message.py::TestFrame::test_multi_tracker
zmq/tests/test_message.py::TestFrame::test_tracker
zmq/tests/test_security.py::TestSecurity::test_curve
zmq/tests/test_security.py::TestSecurity::test_plain
zmq/tests/test_socket.py::TestSocket::test_large_send
zmq/tests/test_socket.py::TestSocket::test_tracker
zmq/tests/test_socket.py::TestSocketGreen::test_large_send

# hanging tests
zmq/tests/test_socket.py::TestSocketGreen::test_tracker
)

pytest -vv ${deselect[@]/#/--deselect } ||
die "Tests failed with ${EPYTHON}"
}

0 comments on commit d7cc2b8

Please sign in to comment.