Skip to content

Commit

Permalink
dev-libs/cygwin: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=header…
Browse files Browse the repository at this point in the history
…s-only

CROSSCOMPILE_OPTS is a USE_EXPAND of a single item: headers-only.
Convert it to a global USE flag instead.

Mechanical ebuild rename done as:
    $ sed -e 's@crosscompile_opts_headers-only@headers-only@g' \
        -i $(git grep -l headers-only)

'headers-only' flag is used by crossdev to bootstrap stage1 compiler
before libc is available.

crossdev switched to USE=headers-only in =sys-devel/crossdev-20171230.

Bug: https://bugs.gentoo.org/642712
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Sergei Trofimovich committed Jan 7, 2018
1 parent d4ea334 commit e182772
Showing 1 changed file with 5 additions and 5 deletions.
10 changes: 5 additions & 5 deletions dev-libs/cygwin/cygwin-1.5.25.15.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2012 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

inherit flag-o-matic toolchain-funcs
Expand All @@ -15,24 +15,24 @@ W32API_BIN="3.12-1"
MY_P="${PN}-${PV%.*}-${PV##*.}"
DESCRIPTION="Linux-like environment for Windows"
HOMEPAGE="http://cygwin.com/"
SRC_URI="!crosscompile_opts_headers-only? ( ftp://sourceware.org/pub/cygwin/release/cygwin/${MY_P}-src.tar.bz2 )
crosscompile_opts_headers-only? (
SRC_URI="!headers-only? ( ftp://sourceware.org/pub/cygwin/release/cygwin/${MY_P}-src.tar.bz2 )
headers-only? (
ftp://sourceware.org/pub/cygwin/release/w32api/w32api-${W32API_BIN}.tar.bz2
ftp://sourceware.org/pub/cygwin/release/cygwin/${MY_P}.tar.bz2
)"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="crosscompile_opts_headers-only"
IUSE="headers-only"
RESTRICT="strip"

DEPEND=""

S=${WORKDIR}

just_headers() {
use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
use headers-only && [[ ${CHOST} != ${CTARGET} ]]
}

pkg_setup() {
Expand Down

0 comments on commit e182772

Please sign in to comment.