forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
x11-libs/libva-intel-driver: bump to 1.7.2
Package-Manager: portage-2.3.0
- Loading branch information
Showing
2 changed files
with
57 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST libva-intel-driver-1.6.2.tar.bz2 1110738 SHA256 bf8759dbcefc82d280c11a5eac5248dce14979c7c58345f218d656d75b0d85fe SHA512 23fefc75a37f9553aeb1611f4d369e1dc0c5d6d0a66ac8c23a14d93bbe8c0da6a5cd1d680feebe8e536d5ebbacc40d6a5f898a0a584885c8989f774a0ae8efac WHIRLPOOL 125787f639149eb072668a8de5c15d305078c968f3ea0b9401c3a02c0f1eb5f9c03685572a202f75597283301bd719d1d6128cb5105f0a404942feae90f63204 | ||
DIST libva-intel-driver-1.7.0.tar.bz2 1114349 SHA256 9d19d6c789a9a4fbce23c4f0eaf993ba776b512bec4c87982ab17ac841435c0c SHA512 9df8aa53a0f24580ef4b9c1ced2a12503755f6e0acc23d7e3784f0a246825cc4e1e9f7ad7f605e47bc67ec1a28008c75c31a807fb97014957065327c02122cd9 WHIRLPOOL 99d55e3b8b06a881e68c5f4e15a6b176004434a77a3c1efb3143a7ad4e3518f4998138bf155c1e3046ae141553bc6abb9c1b1fcebdd6015bd1f11324d7cbe956 | ||
DIST libva-intel-driver-1.7.1.tar.bz2 1224635 SHA256 1ed7717a4058030d381a07c1afe53781ccdcc8643edbc02e769f5b72a316dcb5 SHA512 dab2a500bdaf1d3b16ff89e775280abd49adec4fc9fbe062b3fe8d1c20b57913d54824f0ee9ad6da848152518c10da23ea68553bb25ec15865ded68d9340abf5 WHIRLPOOL eda8dc00e9aa5ae312db88ef7553c9e189d957c8b7348962b1c238346defefe61b24d65472fd813584a9fa9bd0c306e30210249c46baa2fc3f636c1544d64681 | ||
DIST libva-intel-driver-1.7.2.tar.bz2 1222487 SHA256 099e7bf6aa826971ec2caff235babf4da995f754e2ca16a73b258671130e67bc SHA512 ccc82dba175101086a26d1d858a89d3d572ea58b9c17bfcc8c5815e0a34f27b54a31d26e35c513166306f12f3cb138a3d037057050f873623e47df613d07c0a6 WHIRLPOOL a52c3163d9db51909f9785c476bdd92477885ec04890eaeff4055c94a8bd22f699c3a0fc19094bf82499a8753a47964f2a5bec8c9cebdc72ebad5f41e0fb5429 |
56 changes: 56 additions & 0 deletions
56
x11-libs/libva-intel-driver/libva-intel-driver-1.7.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,56 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
SCM="" | ||
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild | ||
SCM=git-2 | ||
EGIT_BRANCH=master | ||
EGIT_REPO_URI="git://anongit.freedesktop.org/git/vaapi/intel-driver" | ||
fi | ||
|
||
AUTOTOOLS_AUTORECONF="yes" | ||
inherit autotools-multilib ${SCM} | ||
|
||
DESCRIPTION="HW video decode support for Intel integrated graphics" | ||
HOMEPAGE="https://www.freedesktop.org/wiki/Software/vaapi" | ||
if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild | ||
SRC_URI="" | ||
S="${WORKDIR}/${PN}" | ||
else | ||
SRC_URI="https://www.freedesktop.org/software/vaapi/releases/libva-intel-driver/${P}.tar.bz2" | ||
fi | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
if [ "${PV%9999}" = "${PV}" ] ; then | ||
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" | ||
else | ||
KEYWORDS="" | ||
fi | ||
IUSE="+drm wayland X" | ||
|
||
RDEPEND=">=x11-libs/libva-1.7.1[X?,wayland?,drm?,${MULTILIB_USEDEP}] | ||
>=x11-libs/libdrm-2.4.46[video_cards_intel,${MULTILIB_USEDEP}] | ||
wayland? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )" | ||
|
||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
DOCS=( AUTHORS NEWS README ) | ||
|
||
src_prepare() { | ||
sed -e 's/intel-gen4asm/\0diSaBlEd/g' -i configure.ac || die | ||
autotools-multilib_src_prepare | ||
} | ||
|
||
multilib_src_configure() { | ||
local myeconfargs=( | ||
$(use_enable drm) | ||
$(use_enable wayland) | ||
$(use_enable X x11) | ||
) | ||
autotools-utils_src_configure | ||
} |