Skip to content

Commit

Permalink
dev-python/denonavr: bump to 0.7.7, add PyPy3 support
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Louis Sautier <[email protected]>
  • Loading branch information
sbraz committed Dec 10, 2018
1 parent fb11fc3 commit e702f0b
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/denonavr/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST denonavr-0.7.5.tar.gz 61972 BLAKE2B 17a6d7079cfea1f349b4ca2eafdfadc7cb1731737c9319d60239710e27608da1bdb0101fb36057a8618ceb0f2573aefc7b14932171e6e5ed2f393dc681f62ea2 SHA512 441b256ad34d7e998381a48d34296404418a8297d24fa7f748540e8daf9b067ca7acef4d04289665204ff1cf63e75333d4d49d173cf0eea42283e6eeedac6de1
DIST denonavr-0.7.6.tar.gz 62285 BLAKE2B 45004465f1d8c371535c0e64b5d6decb224a80a986a5bfb1a960d320564e28a152a06c3c5375013261110a1d7c23ee301166580614dd1a727dac296c38b38899 SHA512 87c35325e46d8dc3129366dc45632705157e793d3faf4377f884b1d40430047fc2ff2613a975d6223a925c8c83c807454c03331b706a2d06474e649bbdb85c10
DIST denonavr-0.7.7.tar.gz 62745 BLAKE2B 56e2ab0430a9b1fbc540b24d279bdab24f1bda2121031c48ace92b81b8a28371fe02a34e8f763b87a83325d522526faa577a85239f02d02fa0e86b928b152200 SHA512 4b17d2f663f8fde88bd67d8050e86c7a5adcf1890ce87c630ffa7f0107267b996234e707770ae56bfe9571335b320b70225d697f1cccc72ba29c765a422b0896
33 changes: 33 additions & 0 deletions dev-python/denonavr/denonavr-0.7.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( pypy3 python3_{4,5,6,7} )
PYTHON_REQ_USE="xml(+)"

inherit distutils-r1

DESCRIPTION="Automation Library for Denon AVR receivers"
HOMEPAGE="https://github.com/scarface-4711/denonavr"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
dev-python/testtools[${PYTHON_USEDEP}]
)
"

python_test() {
pytest -vv || die "tests failed with ${EPYTHON}"
}

0 comments on commit e702f0b

Please sign in to comment.