Skip to content

Commit

Permalink
dev-python/keystoneauth: Bump to 5.1.1
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jan 4, 2023
1 parent c724c55 commit ece7e21
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/keystoneauth/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST keystoneauth1-5.1.0.tar.gz 269600 BLAKE2B 5ea3885f34fe96f9a07f7bb5cbcadb1382ae5b06ae7afb627ad6b25b8b6d17ba5448f78cdcf1d89dd799d062950a8b66a1f58c5779fee7615db97557eb4ee9fa SHA512 1bb17818524256cf1a6a73d9bdd933451dae34f89be0fc6fb6a88f2207ce6b068e086b463abb904b0c9c20a9450b208321026c980e7af2cbbddc5bd75ee20d5b
DIST keystoneauth1-5.1.1.tar.gz 269800 BLAKE2B 413149a14837ec4aebbb6e3a35ff3296ca0427a585262131373b57a53b6eddd1d61701a5eef705ab4db9e528c39a17e916b07615e7f41681cb4dd0f14583a851 SHA512 0c84e0e2bc251fdff54fb4fa7efa65e60865224c48da9a8b3f548101e828516d1cdb33d4a966015384a7107af7754017d6483c9d43a05788030a65766686ba48
64 changes: 64 additions & 0 deletions dev-python/keystoneauth/keystoneauth-5.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )

inherit distutils-r1

DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
HOMEPAGE="https://github.com/openstack/keystoneauth"
HOMEPAGE="
https://opendev.org/openstack/keystoneauth/
https://github.com/openstack/keystoneauth/
https://pypi.org/project/keystoneauth1/
"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
S="${WORKDIR}/${PN}1-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"

RDEPEND="
>=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
>=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
>=dev-python/six-1.10.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
>=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
"
BDEPEND="
>=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
test? (
>=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
>=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
>=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
>=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
>=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
>=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
>=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
>=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
>=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
>=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
)
"

distutils_enable_tests unittest

src_prepare() {
# relies on specific test runner name
sed -i -e 's:run\.py:unittest_or_fail.py:' \
keystoneauth1/tests/unit/test_session.py || die
# remove the test that requires hacking
rm keystoneauth1/tests/unit/test_hacking_checks.py || die
distutils-r1_src_prepare
}

python_test() {
eunittest -b
}

0 comments on commit ece7e21

Please sign in to comment.