forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/gst-plugins-base: bump to 1.12.4 for upstream bug fixes
Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
90 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gst-plugins-base-0.10.36.tar.xz 2364108 BLAKE2B a71ef5d5c7462d60937602681c060e85ed086a753b7ef354dad48354d6c3741d809f2c0c6a321ef9ac60fb12d24ec65e1baa63e51211134d2a5e03aae16f73d2 SHA512 ea77778e073515df58229a641b4363df31f0b80204a5a43a8feb31f0b03a5a4b9b79d6e07e1615c773a59927a9b649f1b1d782def1120d581d09a090be8363b8 | ||
DIST gst-plugins-base-1.12.3.tar.xz 3117364 BLAKE2B c5c16f1b46b10cfc5b9731ea990638238b82eb7f312345fece3826deed20992aff1c5a48e031060dc175b5ab5ad8ee21bb3e1e950fc0681ee4b596e65f5f92fe SHA512 d32f71836e25081b00040709a2184da85489e5af90902a0b27b820a478f5805bde93a04cefaeabf36dde53c16ad12f2816777cc195f1e027f19d1883e088e2b2 | ||
DIST gst-plugins-base-1.12.4.tar.xz 3119468 BLAKE2B d5ac157618a25c8f0323d1922d5b26b0b5c49f56cb75df3ceeadd0566f873be1a06c863a1da6afff40901fbbbeb1ec6cd6ef4614309ca7f7ff988c0fa9040a10 SHA512 89a6e92cd294612cf1406eb156416ab4606643f6b43637e64a18f6f28ab789ca8d4cf1308434ed85e5fc679c79cc3ca115db48f37e0065a6ab3cdfdbaaad9f53 |
89 changes: 89 additions & 0 deletions
89
media-libs/gst-plugins-base/gst-plugins-base-1.12.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,89 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
GST_ORG_MODULE="gst-plugins-base" | ||
|
||
inherit gstreamer | ||
|
||
DESCRIPTION="Basepack of plugins for gstreamer" | ||
HOMEPAGE="https://gstreamer.freedesktop.org/" | ||
|
||
LICENSE="GPL-2+ LGPL-2+" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris" | ||
|
||
IUSE="alsa +introspection ivorbis +ogg +orc +pango theora +vorbis X" | ||
REQUIRED_USE=" | ||
ivorbis? ( ogg ) | ||
theora? ( ogg ) | ||
vorbis? ( ogg ) | ||
" | ||
|
||
RDEPEND=" | ||
app-text/iso-codes | ||
>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}] | ||
>=media-libs/gstreamer-${PV}:1.0[introspection?,${MULTILIB_USEDEP}] | ||
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] | ||
alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] ) | ||
introspection? ( >=dev-libs/gobject-introspection-1.31.1:= ) | ||
ivorbis? ( >=media-libs/tremor-0_pre20130223[${MULTILIB_USEDEP}] ) | ||
ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] ) | ||
orc? ( >=dev-lang/orc-0.4.24[${MULTILIB_USEDEP}] ) | ||
pango? ( >=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}] ) | ||
theora? ( >=media-libs/libtheora-1.1.1[encode,${MULTILIB_USEDEP}] ) | ||
vorbis? ( >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}] ) | ||
X? ( | ||
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] | ||
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}] | ||
>=x11-libs/libXv-1.0.10[${MULTILIB_USEDEP}] ) | ||
" | ||
DEPEND="${RDEPEND} | ||
>=dev-util/gtk-doc-am-1.12 | ||
X? ( | ||
>=x11-proto/videoproto-2.3.1-r1[${MULTILIB_USEDEP}] | ||
>=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}] | ||
>=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] ) | ||
" | ||
RDEPEND+="!<media-libs/gst-plugins-bad-1.11.90:1.0" # rawparse move | ||
|
||
multilib_src_configure() { | ||
gstreamer_multilib_src_configure \ | ||
$(use_enable alsa) \ | ||
$(multilib_native_use_enable introspection) \ | ||
$(use_enable ivorbis) \ | ||
$(use_enable ogg) \ | ||
$(use_enable orc) \ | ||
$(use_enable pango) \ | ||
$(use_enable theora) \ | ||
$(use_enable vorbis) \ | ||
$(use_enable X x) \ | ||
$(use_enable X xshm) \ | ||
$(use_enable X xvideo) \ | ||
--enable-iso-codes \ | ||
--enable-zlib \ | ||
--disable-debug \ | ||
--disable-examples \ | ||
--disable-static | ||
# cdparanoia and libvisual are split out, per leio's request | ||
|
||
# bug #366931, flag-o-matic for the whole thing is overkill | ||
if [[ ${CHOST} == *86-*-darwin* ]] ; then | ||
sed -i \ | ||
-e '/FLAGS = /s|-O[23]|-O1|g' \ | ||
gst/audioconvert/Makefile \ | ||
gst/volume/Makefile || die | ||
fi | ||
|
||
if multilib_is_native_abi; then | ||
local x | ||
for x in libs plugins; do | ||
ln -s "${S}"/docs/${x}/html docs/${x}/html || die | ||
done | ||
fi | ||
} | ||
|
||
multilib_src_install_all() { | ||
DOCS="AUTHORS NEWS README RELEASE" | ||
einstalldocs | ||
prune_libtool_files --modules | ||
} |