Skip to content

Commit

Permalink
dev-libs/mongo-c-driver: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
ultrabug committed Sep 17, 2015
1 parent eca07aa commit efd1455
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/mongo-c-driver/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST mongo-c-driver-0.7.1.tar.gz 108537 SHA256 6670b50bb4232cc617a114d1320ea97abc55f9570b4ebf53e1e6c22671ffc328 SHA512 5c6996dc47ecbe4d77971e3aa983a877e7de736bf358c467808eceba8b1a5eea342376249cdc682a034fc7ec39290d234527cec3c3732686f184281a72aec724 WHIRLPOOL c3aadbb61bd7bd295398b4510708f95c0a05383e80baba510609870aa39f5442d4bbfb6441889f605578e07e2c97d44d2e2d75b5a2ec6950a362825c6110fbd3
DIST mongo-c-driver-0.8.1.tar.gz 124053 SHA256 9575f05fa87fe1f7c6562b1ec9202fd4b8a98950a4d65ea44c1c62fadc2b48b0 SHA512 7b61ac4b1b154ee1f518eddb2bbc0cdafe0da8786eed4475e5703c2a735ec5a09efde59f5bfa45fb226cbce24d8c0ba0de403d8fc3e561c0e48507dfb07962b1 WHIRLPOOL 1474a7b5fced35b511cedd97f558f284d70135c591bd6d671c34519f68097a1e2e6a32a6323acfa4ea3d0146529d3be79f2f91d1187ba3d01a7da6aaacaabf2d
DIST mongo-c-driver-0.98.2.tar.gz 5342760 SHA256 ac0edebd6ee55ac5c63047addc67d1801440586e6a9388cb3938c5bb0319afc5 SHA512 6e3abc31b1e0e02d3bb864882444a95aa01ec4a85ee77abdc52675a730790be7f1924f3c6ea36405ff0f2066e332302ca567bbfa35ba7b918bce81fb409600eb WHIRLPOOL 931a20b916778fcff0d419a73e1263b72b3293ce320254b050ed2211b56449e5e8dcd608459dcce8af98922e64a4aefc2908883f12a590d9e3e754573aed17c1
DIST mongo-c-driver-1.1.10.tar.gz 5321144 SHA256 19c076fcca1e7b22a731f10b757a049fd94b4aee6bbd0d7b7a0bcbd454e9dee8 SHA512 10ebd1bddc0c713c0934679974fb1ed29eda1bf8e2ebbe2a1ebbcba219574092c34c4b352231ec65ffe3e350d8d701ef85debaaa9f9c10e6ab36fc3fa29f69df WHIRLPOOL ee42e78fbab15b964a04ec70c4a782bb7cd0c46275619b46d32b2c00094df90e3de4a756e6f8496fec87a596af23a403d3cf33b391309e8a044334cbaec58a06
DIST mongo-c-driver-1.1.2.tar.gz 5443153 SHA256 ba97f4304883abf6d57ac96751260c4b413b871b0779c12e67136320bee5f118 SHA512 d420fc407f6a04c06a959b8971dc2643c987df5c3d82f2b13bfdf6a44e96bc377478c4d0e385abf67f21b56892c915c79675fe9ebf6efa9aab51fe452c5e6f95 WHIRLPOOL d72bdd7e449e8437bc9742e5f0330e6f6c47d40e3fc07a17d95a9967ecb2ae5961f5c7c155e2d8a12e733139ffbf30091dfa283f6f6a694e05c9c9fb7a03bd2b
68 changes: 68 additions & 0 deletions dev-libs/mongo-c-driver/mongo-c-driver-1.1.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit autotools eutils

DESCRIPTION="A high-performance MongoDB driver for C"
HOMEPAGE="https://github.com/mongodb/mongo-c-driver"
SRC_URI="https://github.com/mongodb/${PN}/releases/download/${PV}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="debug examples sasl ssl static-libs test"

RDEPEND=">=dev-libs/libbson-1.1.10
sasl? ( dev-libs/cyrus-sasl )
ssl? ( dev-libs/openssl:= )"
DEPEND="${RDEPEND}
test? ( dev-db/mongodb )"

DOCS=( NEWS README.rst TUTORIAL.md )

src_prepare() {
rm -r src/libbson || die
sed -i -e '/SUBDIRS/s:src/libbson::g' Makefile.am || die

# https://github.com/mongodb/mongo-c-driver/issues/54
sed -i -e "s/PTHREAD_LIBS/PTHREAD_CFLAGS/g" src/Makefile.am \
tests/Makefile.am || die
eautoreconf
}

src_configure() {
econf --with-libbson=system \
--disable-hardening \
--disable-optimizations \
--disable-examples \
$(use_enable sasl) \
$(use_enable ssl) \
$(use_enable debug) \
$(use_enable static-libs static)
}

src_install() {
emake DESTDIR="${D}" install
doman doc/*.3

use static-libs || find "${D}" -name '*.la' -delete

if use examples; then
insinto /usr/share/${PF}/examples
doins -r examples/*.c examples/aggregation examples/bulk
fi
}

src_test() {
# Avoid allocating too much disk space by using server.smallFiles = 1
echo -e "storage:\n smallFiles: true" > "${T}/mongod.conf"
local PORT=27099
mongod --port ${PORT} --bind_ip 127.0.0.1 --nounixsocket --fork \
-f "${T}/mongod.conf" --dbpath="${T}" \
--logpath="${T}/mongod.log" || die
MONGOC_TEST_HOST="127.0.0.1:${PORT}" emake test
kill `cat "${T}/mongod.lock"`
}

0 comments on commit efd1455

Please sign in to comment.