Skip to content

Commit

Permalink
x11-terms/xterm: Version bump to 327
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
  • Loading branch information
mrueg committed Oct 10, 2016
1 parent 11d9829 commit f1ab3dc
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-terms/xterm/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST xterm-314.tgz 1200426 SHA256 1dbf1e93796c1b71b22b84e82eb58bcf20a14a7f365158
DIST xterm-320.tgz 1217356 SHA256 a60dbb574334c081425fa30f011cd9f571e3be7a91e2a84e252461798bce24a7 SHA512 6c234b5564ce1276136bc3ef8ef5d6703ed9dc3af3b0fd7c8c713c0876276fc4bb55cee7137f9a8c45df66531b6bd8eb778bd7660ea35c4aa8aa80ba17ba1263 WHIRLPOOL 2d7b0de46096a7a0426a419007a590bc478d19c7e2ddc3cea2fbfe0998a2f2fe5c6f5da46b5869260207e897a284250fa2cd483d613d65636c01ce366d7b6a5c
DIST xterm-325.tgz 1237865 SHA256 3b31b07a0c40427e9330ec3be9d1a748c72808f945953cea9e526e48be315f1b SHA512 7049a013967cb90eb196684e7d6d0664cd0d7c86154fba318493d9249e973a4bf591861cbbc051a80184ef427aad75774b15d79cb571d3f82482c1b51e7a99f4 WHIRLPOOL 5f08712994e3d907fcae2bbfe7d8f1aaf2ff3be342eec6b854f94774d0e7fa03e042c2716848b6aae6d6cf14a030c7a1769b6ab8e68818394447acf2455cd37e
DIST xterm-326.tgz 1240064 SHA256 3f40eb373cef578ae108b6d19602c96bf7342a80396e93a30ff78ee72f68d317 SHA512 24a26adeeb07f2ed31779578d3a18d6c838bc7596521f5c826c8747b96fae1a296451f55d0046970102cf9f2ef072f6d0505dfc51378796c2834fb9af036dce1 WHIRLPOOL 132c330e9f476bf1050efd5f054be22959e0abd6e44eac247e27248f805c42691a12c061864e033ca9199dfe3f20c50df0a03f6222965a18f0587a965cff7e32
DIST xterm-327.tgz 1240131 SHA256 66fb2f6c35b342148f549c276b12a3aa3fb408e27ab6360ddec513e14376150b SHA512 d9d9f3b870fea8db9ae3c076a9d85152488b2d392b9b1e2e4ebbeded287ed4911f1f63e5e035d5b3793b2506b993125c6fca437393b435a28aeb519d76147672 WHIRLPOOL 44254647e9e6e331d198763c5d38738ebf56386e9c93ee65beaf15ad5d0eb2f75731498608e1e9d503e7d2355a0a456336bcaa4b1d16ab791961cfa404a9489d
94 changes: 94 additions & 0 deletions x11-terms/xterm/xterm-327.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils flag-o-matic multilib

DESCRIPTION="Terminal Emulator for X Windows"
HOMEPAGE="http://invisible-island.net/xterm/"
SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="+openpty toolbar truetype unicode Xaw3d xinerama"

COMMON_DEPEND="kernel_linux? ( sys-libs/libutempter )
kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
>=sys-libs/ncurses-5.7-r7:0=
x11-apps/xmessage
x11-libs/libX11
x11-libs/libXaw
x11-libs/libXft
x11-libs/libxkbfile
x11-libs/libXmu
x11-libs/libXrender
x11-libs/libXt
unicode? ( x11-apps/luit )
Xaw3d? ( x11-libs/libXaw3d )
xinerama? ( x11-libs/libXinerama )"
RDEPEND="${COMMON_DEPEND}
media-fonts/font-misc-misc"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
x11-proto/kbproto
x11-proto/xproto"

DOCS=( README{,.i18n} ctlseqs.txt )

pkg_setup() {
DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
}

src_configure() {
# 454736
# Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
# something sane like pkg-config or ncurses5-config and stops guessing libs
# Everything gets linked against ncurses anyways, so don't shout
append-libs $(pkg-config --libs ncurses)

econf \
--libdir="${EPREFIX}"/etc \
--disable-full-tgetent \
--with-app-defaults="${DEFAULTS_DIR}" \
--disable-setuid \
--disable-setgid \
--with-utempter \
--with-x \
$(use_with Xaw3d) \
$(use_with xinerama) \
--disable-imake \
--enable-256-color \
--enable-broken-osc \
--enable-broken-st \
--enable-exec-xterm \
$(use_enable truetype freetype) \
--enable-i18n \
--enable-load-vt-fonts \
--enable-logging \
$(use_enable openpty) \
$(use_enable toolbar) \
$(use_enable unicode mini-luit) \
$(use_enable unicode luit) \
--enable-wide-chars \
--enable-dabbrev \
--enable-warnings
}

src_install() {
default

dohtml xterm.log.html
domenu *.desktop

# Fix permissions -- it grabs them from live system, and they can
# be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
# respectively (#69510).
# (info from Thomas Dickey) - Donnie Berkholz <[email protected]>
fperms 0755 /usr/bin/xterm

# restore the navy blue
sed -i -e "s:blue2$:blue:" "${D}${DEFAULTS_DIR}"/XTerm-color || die
}

0 comments on commit f1ab3dc

Please sign in to comment.