Skip to content

Commit

Permalink
dev-python/flask-testing: add Python 3 support, fix tests and depende…
Browse files Browse the repository at this point in the history
…ncies

Package-Manager: portage-2.2.28
Closes: gentoo#1293

Signed-off-by: Ian Delaney <[email protected]>
  • Loading branch information
sbraz authored and Ian Delaney committed Apr 18, 2016
1 parent 69b1ea1 commit f40039c
Show file tree
Hide file tree
Showing 2 changed files with 8 additions and 7 deletions.
13 changes: 6 additions & 7 deletions dev-python/flask-testing/flask-testing-0.4.2.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )

inherit distutils-r1

Expand All @@ -20,18 +20,17 @@ KEYWORDS="amd64 x86"
IUSE="test"

RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
dev-python/twill[${PYTHON_USEDEP}]"
$(python_gen_cond_dep 'dev-python/twill[${PYTHON_USEDEP}]' python2_7)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/blinker[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
)"
S="${WORKDIR}/${MY_P}"

PATCHES=( "${FILESDIR}"/${PV}-test-fix.patch )

python_test() {
# test phase appears to run only py2.7 but if it passes for py2.7 is passes for pypy
nosetests || die "Testing failed with ${EPYTHON}"
esetup.py test
}
2 changes: 2 additions & 0 deletions dev-python/flask-testing/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -7,5 +7,7 @@
</maintainer>
<upstream>
<remote-id type="pypi">Flask-Testing</remote-id>
<remote-id type="github">jarus/flask-testing</remote-id>
<bugs-to>https://github.com/jarus/flask-testing/issues</bugs-to>
</upstream>
</pkgmetadata>

0 comments on commit f40039c

Please sign in to comment.