forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-arch/unrar: Bump to version 5.4.5
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
Aug 16, 2016
1 parent
6182a16
commit fcc2e00
Showing
2 changed files
with
64 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST unrarsrc-5.3.11.tar.gz 223663 SHA256 77b87af4b2976ef7c6b0c79e071284c2c1b035a9543273ec925f9d92f73b8763 SHA512 14ea833fe4c2d81718df25794d2e795a255f92c68a5533d6a7d2cbfc072db3ce07bba7ba1fd5555aad1a17fbaf4980eb217a7d9f6158461fa917e1a17590569b WHIRLPOOL 60c909d9005cb0e2cfbef606b2dc66d9f7b3fd019fbf8ad83ce8b07f9e11c1890db175836ee3e63a21aa2f309ac0ebfebcf2ed5f60ca321a9b8a1b89409b1331 | ||
DIST unrarsrc-5.4.3.tar.gz 226066 SHA256 e4f05190d9e379449a04c22baffc24cc2f03164a4738befe601b1325440db0c6 SHA512 47bf658146037df203babb34f7c3572b685c016ba6f5e148d8af08605554f561dea4a54b7f0402d5715772f1aea43e60b0769d0e48ef544bc51afb6f4b608e30 WHIRLPOOL 57f0a99d78ca350d72982417dc4c3c156920af6cf27b77fa8a7c13ab41a60a25ff67acd40e7afac466f14a6113c797203f5ad4d25343dda4a411867317404af0 | ||
DIST unrarsrc-5.4.4.tar.gz 226097 SHA256 556b65d61164b018c4a3ce10e6290b16f4d042a603f6a4e17f74b19ac25d2d83 SHA512 496646b851bae4ac2c5b4f62a41265ba0d63e8ec58fa66b1801d971186b58e305a8d44a212e8fe035a82bf0b599eeb35e881dc62e8d75a1a5c7c54ce26aad1d6 WHIRLPOOL 35a84ff2247d2f886237721a978ac784426c9968b57d8928aab10d895504bac53040f121bf54c445eaedba6d237c1dda7544ffa4195bc0da7162c1c5f6d485e4 | ||
DIST unrarsrc-5.4.5.tar.gz 226320 SHA256 e470c584332422893fb52e049f2cbd99e24dc6c6da971008b4e2ae4284f8796c SHA512 ba2abf11638b5ee026cb9e0c3576c94376a01ab3c5411b9bd0e8116d64879c81e76df16f98d850f0f0f5387dda046f38be64ddfb4fe57431cc4d97066d6e3c2f WHIRLPOOL c8e035ec183f41d8faf8345b49d2a4d20e21f9c6e27f14d7794389942df4954cd66ab4a5be2fdff6d369b514ae99d5d015f35a36143d686563b2a8efdfc77dce |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,63 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
|
||
inherit eutils flag-o-matic multilib toolchain-funcs | ||
|
||
MY_PN=${PN}src | ||
|
||
DESCRIPTION="Uncompress rar files" | ||
HOMEPAGE="http://www.rarlab.com/rar_add.htm" | ||
SRC_URI="http://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz" | ||
|
||
LICENSE="unRAR" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris" | ||
IUSE="" | ||
|
||
RDEPEND="!<=app-arch/unrar-gpl-0.0.1_p20080417" | ||
|
||
S=${WORKDIR}/unrar | ||
|
||
src_prepare() { | ||
epatch "${FILESDIR}"/${PN}-5.0.2-build.patch | ||
epatch "${FILESDIR}"/${PN}-5.2.2-no-auto-clean.patch #528218 | ||
local sed_args=( -e "/libunrar/s:.so:$(get_libname ${PV%.*.*}):" ) | ||
if [[ ${CHOST} == *-darwin* ]] ; then | ||
sed_args+=( -e "s:-shared:-dynamiclib -install_name ${EPREFIX}/usr/$(get_libdir)/libunrar$(get_libname ${PV%.*.*}):" ) | ||
else | ||
sed_args+=( -e "s:-shared:& -Wl,-soname -Wl,libunrar$(get_libname ${PV%.*.*}):" ) | ||
fi | ||
sed -i "${sed_args[@]}" makefile || die | ||
} | ||
|
||
src_configure() { | ||
mkdir -p build-{lib,bin} | ||
printf 'VPATH = ..\ninclude ../makefile' > build-lib/Makefile || die | ||
cp build-{lib,bin}/Makefile || die | ||
} | ||
|
||
src_compile() { | ||
unrar_make() { | ||
emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" STRIP=true "$@" | ||
} | ||
|
||
unrar_make CXXFLAGS+=" -fPIC" -C build-lib lib | ||
ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname) || die | ||
ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname ${PV}) || die | ||
|
||
unrar_make -C build-bin | ||
} | ||
|
||
src_install() { | ||
dobin build-bin/unrar | ||
dodoc readme.txt | ||
|
||
dolib.so build-lib/libunrar* | ||
|
||
insinto /usr/include/libunrar${PV%.*.*} | ||
doins *.hpp | ||
dosym libunrar${PV%.*.*} /usr/include/libunrar | ||
} |